node5.1使用npm安装依赖时提示 node/NAN/v8 requires a C++11 compiler

问题:Centos6.5 x64环境node5.1使用npm安装依赖时提示 requires a C++11 compiler错误

解决方法:

由于node4.0升级了v8引擎,编译时需要gcc4.8以上版本,Centos6自带的gcc为gcc-4.4.7,不支持编译所需的C++11标准,所以只好升级gcc(devtoolsset-3 -> gcc-4.9)(直接升级到最新)

 

发表评论

电子邮件地址不会被公开。 必填项已用*标注